87 325es Coolant Warning Light Stays On - BMW Forum - BimmerWerkz.com
3-Series (E21, E30) Chat relating to the BMW 3-Series from 1975-1983 and 1984-1991 line. Specific models: BMW 315, BMW 316, BMW 318, BMW 318i, BMW 320/4, BMW 320i, BMW 320/6, BMW 323i, BMW 320i. E30 Family models include: BMW 325e, BMW 325i, BMW 325is, BMW 325ix.

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 06-01-2009, 11:56 AM
n00b
 
Join Date: May 2009
Posts: 28
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
terriibleted65 is on a distinguished road
(Thread Starter)
87 325es Coolant Warning Light Stays On

I have filled the coolant to the recommended height but the coolant light stays on. Any suggestions?

...just bought the car this weekend so I am going through the issues I find...thanks for your help and sorry if this is a repeat post as I could not find this topic. - Ted

terribleted65 - new to bmw restoration but have restored 63 ford fairlane and 68 mustang conv. I look forward to the bmw experience.
terriibleted65 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 06-01-2009, 12:20 PM
OMFG another one!?
 
witeshark's Avatar
 
Join Date: Aug 2004
Location: Miami FL
Posts: 14,697
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
witeshark is just really nice witeshark is just really nice witeshark is just really nice witeshark is just really nice witeshark is just really nice
There's likely air in the system that must be bled out.

BMW

Sig by zeaq
witeshark is offline  
#3 (permalink) Old 06-01-2009, 07:53 PM
n00b
 
Join Date: May 2009
Posts: 28
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
terriibleted65 is on a distinguished road
(Thread Starter)
drain and fill, work?

i was going to perform a drain and refill on the coolant anyways since there are no records on when it was done last...will this likely remedy my 'air' situation?

terribleted65 - new to bmw restoration but have restored 63 ford fairlane and 68 mustang conv. I look forward to the bmw experience.
terriibleted65 is offline  
#4 (permalink) Old 06-01-2009, 08:31 PM
OMFG another one!?
 
witeshark's Avatar
 
Join Date: Aug 2004
Location: Miami FL
Posts: 14,697
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
witeshark is just really nice witeshark is just really nice witeshark is just really nice witeshark is just really nice witeshark is just really nice
Only if the air is carefully bled out.

BMW

Sig by zeaq
witeshark is offline  
#5 (permalink) Old 06-01-2009, 09:16 PM
Im Bluffin With My Muffin
 
AlpineSixAndSeven's Avatar
 
Join Date: Nov 2006
Location: Palo Alto, CA
Posts: 5,992
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold
Send a message via AIM to AlpineSixAndSeven
My e30 had the same issue Normally it is the sensor has gone bad there cheap to replace...

1991 Ford Taurs SHO 5 Speed White on Tan
1996 Chevy Lumina LTZ Rep 3.4L
1992 318i Coupe parts car
1992 325i Ls1 swap with a T56 6 speed 12.2 quarter mile
1976 Mercedes Benz 300D with a Ford 5.0L Fuel Injected soon to be Modded
I am Captain Obvious
AlpineSixAndSeven is offline  
#6 (permalink) Old 06-17-2009, 04:32 AM
n00b
 
sunkist_drop's Avatar
 
Join Date: Nov 2007
Location: germany
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
sunkist_drop is on a distinguished road
Send a message via Yahoo to sunkist_drop
Quote:
Originally Posted by AlpineSixAndSeven View Post
My e30 had the same issue Normally it is the sensor has gone bad there cheap to replace...

You have a pic of the sensor??
sunkist_drop is offline  
#7 (permalink) Old 06-17-2009, 09:30 AM
1st Gear Member
 
romeomike's Avatar
 
Join Date: Mar 2009
Location: Las Vegas
Posts: 125
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
romeomike is on a distinguished road
romeomike is offline  
#8 (permalink) Old 06-17-2009, 07:20 PM
2nd Gear Member
 
Join Date: Oct 2008
Posts: 493
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
silversled can only hope to improve
what I do is fill the coolant resevour a little at a time while the engine is just a little bit warm, so that the cap comes off without spraying stuff all over the place but keeping the thermostat open...there's a point in there where you have both conditions...then I top the coolant off a little bit at a time and squeeze the radiator hoses one by one until no squishing sound. I always see the coolant level in the tank lower, then I add more coolant and do it again...eventually the system is stocked......button it up and there you go...good luck....
silversled is offline  
#9 (permalink) Old 06-18-2009, 05:19 PM
n00b
 
Join Date: May 2009
Posts: 28
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
terriibleted65 is on a distinguished road
(Thread Starter)
thanks. i had a complete flush and fill done on the coolant system and I am still seeing the light. probably a bad sensor at this point. will try that.

terribleted65 - new to bmw restoration but have restored 63 ford fairlane and 68 mustang conv. I look forward to the bmw experience.
terriibleted65 is offline  
#10 (permalink) Old 06-18-2009, 06:48 PM
2nd Gear Member
 
Join Date: Oct 2008
Posts: 493
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
silversled can only hope to improve
whatever, the only thing that trips the telltale lamp in the cabin is the cap on the overflow/filler tank.....that's it....try tapping the plunger on the cap and see if doesn't release....just a guess, but's that only thing that triggers that light...now...if the temp gauge runs high that's an issue.....
silversled is offline  
#11 (permalink) Old 10-05-2009, 04:48 PM
n00b
 
Join Date: May 2009
Posts: 28
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
terriibleted65 is on a distinguished road
(Thread Starter)
changed the sensor this weekend...fixed the issue immediately...now I wish all of the repairs were that simple. :-)

terribleted65 - new to bmw restoration but have restored 63 ford fairlane and 68 mustang conv. I look forward to the bmw experience.
terriibleted65 is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E21, E30)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem: Coolant Warning Came on Lastb0isct 5-Series (E12,E28, E34, E39, E60) 6 03-16-2006 07:29 AM
523i And The Warning Light Stays On DuncanThomas 5-Series (E12,E28, E34, E39, E60) 1 11-05-2004 04:38 PM
Coolant Level Warning 91525i 5-Series (E12,E28, E34, E39, E60) 2 08-06-2004 10:32 AM
Warning about using water as coolant nycbmw325is 3-Series (E36) 7 08-05-2004 04:18 PM
Light stays on Toxic 5-Series (E12,E28, E34, E39, E60) 2 03-22-2004 12:36 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome