'84 318i - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E21, E30)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

3-Series (E21, E30) Chat relating to the BMW 3-Series from 1975-1983 and 1984-1991 line. Specific models: BMW 315, BMW 316, BMW 318, BMW 318i, BMW 320/4, BMW 320i, BMW 320/6, BMW 323i, BMW 320i. E30 Family models include: BMW 325e, BMW 325i, BMW 325is, BMW 325ix.

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 08-25-2003, 09:47 PM   #1 (permalink)
n00b
 
Join Date: Aug 2003
Car:
Posts: 1
Photos:
MadC1rcle is an unknown quantity at this point
I recently bought an '84 318i. It ran great for the last few months but just recently it's been having problems. It starts fine but the idles a little weird. Then when I try to drive it it barely goes, it has no power. It only revs up to 1500rpms at most and I can only get it up to about 20, 25mph. If I push the peddle down half way it drives a little, but when I floor it it cuts out and only revs but struggles. I checked the plugs and there were pretty bad. I cleaned them and it seemed to work. I got new plugs and it ran good for about a day then started acting the same way. I replaced the fuel filter but that didn't help. I don't know what else to do or where else to start. Do you think it could be my fuel injectors? Please let me know if you have any suggestions! Thank you so much for all your help.
MadC1rcle is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-26-2003, 08:25 PM   #2 (permalink)
n00b
 
Join Date: Aug 2003
Car:
Posts: 5
Photos:
keystothebimma is an unknown quantity at this point
OMFG i had the exact same problem and i have a 84 318i also but i did alot i replaced the fuel filter i clean the injectors i got new plugs and new wires and i play with the distributer then it was fixed so do all that and it should be fixed...
keystothebimma is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E21, E30)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
An ALPINA 318i!? I'm I seeing correct? Delmarco 3-Series (E36) 1 09-10-2005 05:09 PM
I May Have Just Acquired An '84 318i... filter27e 3-Series (E21, E30) 9 04-08-2005 05:25 PM
Couple Of Problems With '84 318i JLew 3-Series (E21, E30) 2 02-02-2005 02:29 AM
Under The 318i Hood! 1995 Vs. 1996! Delmarco 3-Series (E36) 13 11-05-2004 08:24 AM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 07:56 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.