325is Running Problems and Installing TPS! HELP! - BMW Forum - BimmerWerkz.com
3-Series (E21, E30) Chat relating to the BMW 3-Series from 1975-1983 and 1984-1991 line. Specific models: BMW 315, BMW 316, BMW 318, BMW 318i, BMW 320/4, BMW 320i, BMW 320/6, BMW 323i, BMW 320i. E30 Family models include: BMW 325e, BMW 325i, BMW 325is, BMW 325ix.

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 03-01-2009, 03:38 PM
1st Gear Member
 
325isBMW1988's Avatar
 
Join Date: Aug 2008
Location: New England
Posts: 123
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
325isBMW1988 is on a distinguished road
Send a message via AIM to 325isBMW1988
(Thread Starter)
Exclamation 325is Running Problems and Installing TPS! HELP!

My e30 is having a terrible time starting and once started it runs like crap until it warms up. After it warms up and i drive it for 15-20 minutes it will start running like crap again like it was when i first got it started. Ive replaced everything to do with the fuel system and intake system except for those 2 brake booster vacuum lines coming out of the right side of the throttle body, but I'm buying those next paycheck. So does anyone know what else could be the problem?

Now for the TPS... Is there any special way or detail i need to worry about when putting on the new TPS?
325isBMW1988 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 03-01-2009, 09:51 PM
2nd Gear Member
 
Join Date: Oct 2008
Posts: 493
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
silversled can only hope to improve
on the cheap, try reseating all of the ignition wires; just pull them (coil included) and reseat them again. Might work, and it's free...they can work themselves a little loose and short out without reason...just a guess, but it doesn't cost nothing to try...good luck
silversled is offline  
#3 (permalink) Old 03-01-2009, 11:28 PM
1st Gear Member
 
325isBMW1988's Avatar
 
Join Date: Aug 2008
Location: New England
Posts: 123
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
325isBMW1988 is on a distinguished road
Send a message via AIM to 325isBMW1988
(Thread Starter)
ill give it a try but i think its a little more difficult of a problem than that, but thanks!
325isBMW1988 is offline  
#4 (permalink) Old 03-02-2009, 12:32 AM
2nd Gear Member
 
Join Date: Oct 2008
Posts: 493
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
silversled can only hope to improve
only reason I mention is that my 1988 325i was pulling the same stunt. A little difficult to start, then ran fine for around 5 minutes, then ran like junk for another 10 minutes and then leveled out and was fine. An intermittant miss I would describe it was. I thought for sure I had a clogged fuel injector(s) but it turned out to be the #6 cylinder plug wire needed to be reseated. Must have been humidity that caused the hard start and then it burned off and then, as I live in chicago and go through many puddles and so forth moisture reaccumulated and caused the engine to revisit the same symtoms. As I was the last one in there on the wires I can only blame myself, anyway, problem solved. My 325i has 172K on it and the fuel injection has been without peer, never one problem with it (and I bought this thing 100K miles ago), it's almost scary as to how reliable this engine has been. I don't even like to look at it any more for fear of jinxing it....damn....anyway..best luck
silversled is offline  
#5 (permalink) Old 03-02-2009, 10:22 AM
1st Gear Member
 
325isBMW1988's Avatar
 
Join Date: Aug 2008
Location: New England
Posts: 123
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
325isBMW1988 is on a distinguished road
Send a message via AIM to 325isBMW1988
(Thread Starter)
its snowing here in New England right now so ill take a look at the wires 2morrow!
325isBMW1988 is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E21, E30)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
1988 325is running problems 325isBMW1988 3-Series (E21, E30) 3 01-20-2009 09:10 PM
'87 325 running problems??? datsunracin 3-Series (E21, E30) 0 10-22-2008 08:51 PM
trouble running RCA cables for sub in 92 325is 92.325is Audio and Electronics 5 08-10-2007 10:18 PM
1989 325i 2dr Intermediate Running Problems CodyB 3-Series (E21, E30) 6 12-09-2005 07:58 AM
Anyone With 93 325is Running M3 Clutch & Flywheel? BMDub325is 3-Series (E36) 4 01-17-2005 03:13 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome