Climate Control Messed Up - BMW Forum - BimmerWerkz.com
1,6,7,8 - Series and Mini Cooper General Chat related to models that do not fit into particular categories above. Please try to put your discussion in more appropriate sections. This section does cover the 1 Series, MINI Cooper and 8-Series vehicles: BMW 830i, BMW 840Ci, BMW 850i, BMW 850Ci, BMW 850CSi, M8, Alpina B12, BMW CS Concept and others.

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 07-02-2005, 03:18 PM
n00b
 
Join Date: Mar 2005
Posts: 47
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
mrclean is an unknown quantity at this point
(Thread Starter)
My climate control has something weird going on. IF I can get it to turn on, it at first does what I program it to do, bi-level, it comes out the front, and the rear blower comes on too. however after about a minute it immediately diverts all air to the defrost vents. Also, to get the climate control module do work I have to usually hit the dash a couple of times then all of a sudden it comes to life. The only button that works everytime is the defrost, which also blows out really hot air, like its the heat. Even though that works, no other buttons do until I hit the dash a couple times. So, whats causing the climate controls to be sporadic, is it a short, or is the module going bad, or what, I'm confused...
mrclean is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 07-02-2005, 08:01 PM
Moderator
 
Dirty_Tool's Avatar
 
Join Date: Apr 2004
Posts: 1,052
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Dirty_Tool has a reputation beyond repute Dirty_Tool has a reputation beyond repute Dirty_Tool has a reputation beyond repute Dirty_Tool has a reputation beyond repute Dirty_Tool has a reputation beyond repute Dirty_Tool has a reputation beyond repute Dirty_Tool has a reputation beyond repute Dirty_Tool has a reputation beyond repute Dirty_Tool has a reputation beyond repute Dirty_Tool has a reputation beyond repute Dirty_Tool has a reputation beyond repute
Sounds like you need to start with replacing or repairing the climate control panel itself 1st and then go from there. Maybe try a local junkyard for the part or maybe somebody here can help with an aftermarket resource.

DT

DT




Dirty_Tool is offline  
#3 (permalink) Old 07-03-2005, 05:33 PM
n00b
 
Join Date: Mar 2005
Posts: 28
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Zulu95 is an unknown quantity at this point
Where are you?
Zulu95 is offline  
#4 (permalink) Old 07-03-2005, 05:51 PM
n00b
 
Join Date: Mar 2005
Posts: 47
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
mrclean is an unknown quantity at this point
(Thread Starter)
Do you mean me? As in location?
mrclean is offline  
#5 (permalink) Old 07-03-2005, 11:08 PM
1st Gear Member
 
FREDPLT's Avatar
 
Join Date: Feb 2005
Location: New Hampshire
Posts: 135
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
FREDPLT is an unknown quantity at this point
Send a message via AIM to FREDPLT
Mr Clean
On my old seven the actual panel went bad first, the buttons would not stay in, thats because they get worn, and then the unit itself went to way of the of the dinosaur. Go and get a new unit for the dash and that may fix your problems!

1998 Cosmos M3
1986 Silver 735i
2000 Gold Tahoe Z71
FREDPLT is offline  
#6 (permalink) Old 07-04-2005, 12:59 AM
n00b
 
Join Date: Mar 2005
Posts: 47
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
mrclean is an unknown quantity at this point
(Thread Starter)
Yeah, some point soon, I'm gonna rip my dash apart to do a bunch of things, like replace the battery in the SI board, look for a short as well, because its causing my dashboard lights to go out sometimes, and then try and get that unit out and see whats going on with it, I'll also go looking for a new climate control module while I'm doing all this. Hopefully after this the dash can stay together.
mrclean is offline  
#7 (permalink) Old 07-05-2005, 07:32 AM
n00b
 
Join Date: Mar 2005
Posts: 28
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Zulu95 is an unknown quantity at this point
As in location.
Zulu95 is offline  
#8 (permalink) Old 07-07-2005, 04:28 PM
n00b
 
Join Date: Mar 2005
Posts: 47
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
mrclean is an unknown quantity at this point
(Thread Starter)
I'm like 25 miles north of NYC in White Plains, NY.
mrclean is offline  
#9 (permalink) Old 08-13-2005, 07:43 PM
n00b
 
Join Date: Mar 2005
Posts: 47
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
mrclean is an unknown quantity at this point
(Thread Starter)
Allright, I got my old climate control module out, and it had a burned out piece on the connector, I put in one that I found at a junkyard, and now it turns on everytime. Unfortunately, that hasn't fixed the air flow problem. When I first turned it on, the air changed from the defrost to the front vents for about 10 seconds, then it all went to the defrost vents again. Hitting any of the buttons doesn't change it. At least it turns on now.....I'm gonna look into a module for the A/C under the dash, do you know what thats called, because thats one of the only other thing I can think of thats broken, because it blows fine when it comes out the front vents, but, doesn't stay on that setting...
mrclean is offline  
#10 (permalink) Old 08-18-2005, 09:35 PM
n00b
 
Join Date: Dec 2004
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
fredrex is an unknown quantity at this point
I think I have the same problem with my climate control. At first, only onside would blow cold air. The driver's side blew cold air while the passenger side didn't. Now as of yesterday, the fan doesn't blow at all. Is my climate control gone?
fredrex is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 1,6,7,8 - Series and Mini Cooper


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
climate control fan speed sanga 5-Series (E12,E28, E34, E39, E60) 4 06-02-2010 11:47 AM
BMW has perhaps the WORST climate control SpeedsterBMW 3-Series (E46, E90) 27 05-03-2010 09:59 AM
Rebuilding your e36 climate control computer 98e36bostonchic OEM Parts 2 10-18-2005 09:09 AM
Climate Control Problems medice10 3-Series (E36) 4 10-09-2005 03:10 PM
Climate Control Rookie 3-Series (E36) 9 03-14-2005 11:51 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome