BMW Forum - BimmerWerkz.com

BMW Forum - BimmerWerkz.com (http://www.bimmerwerkz.com/forum/)
-   1,6,7,8 - Series and Mini Cooper (http://www.bimmerwerkz.com/forum/1-6-7-8-series-mini/)
-   -   2001 740i radio/nav (http://www.bimmerwerkz.com/forum/1-6-7-8-series-mini/2001-740i-radio-nav-71460.html)

pman54 09-14-2010 08:46 PM

2001 740i radio/nav
 
Im Looking at picking up a 01 740 i, noticed that the wide screen display doesnt light up. the radio will play for alittle while then cuts off you have to turn off the radio then turn it back on, but it still goes out. any ideas??????/ Also is this sight for 3 & 5 series folks?

brettski 09-15-2010 08:32 AM

Welcome to the Werkz.
Good to see another 7 member. It could be that the backlighting on the dispay is out. You can check this by getting a bright light onto the display and see if there is anything in the background.

All sort of models are represented on this site. Enjoy your time here.

rconnolly 09-16-2010 11:34 AM

I have the same issue with my 2001 740iL. I was told that this was a problem with that year as it's the 1st year for the GPS which runs through the radio. It has been speculated that switching out the radio to a new system (from a BEST BUY or similar) will correct the problem as it's the unit not the wiring. Any thoughts?

pman54 09-17-2010 12:57 AM

Bought the car today, notice tonight that the screen is litup but nothing is displayed. CD and radio will play for short periods of time then stops, I have to turn the power off then on and it will play. Anyone exp this.

brettski 09-17-2010 08:52 AM

Does the display show anything at all when you turn the TC, CD & Radio off? You should see a front menu with phone, gps etc?

rconnolly 09-17-2010 09:30 AM

When it happens to mine the screen is either black, lighted but with no images or images showing but unresponsive from the dashboard but i can adjust volume & stations (or CD) from steering wheel controls.

pman54 09-17-2010 11:57 AM

i get nothing, just a blue back lit screen. when you turn off, it just off not back lit

pman54 09-17-2010 12:45 PM

ive disconnected the nav unit in the trunk and nothing. the radio plays but still cuts out after aboutn 5 min

Mickeyd80 11-01-2012 03:24 PM

Did anyone get a resolution to this? My 2001 740 now has the same symptoms?

marti5 11-07-2012 02:41 AM

It will more than likely be the video module in the trunk behind the carpeted area to the left, you will have to release the nave unit the the carpet can be removed, there you will see one of these:

BMW E39 , E46 , E38, E53 5 ,3, 7, X5 seris 16;9 TV tuner , video modul | eBay

TheCEO 11-25-2012 12:43 PM

I have a 99 740i w/nav and I get not only what u describe, but.....THE WORST STATIC NOISE ever heard this side of a sasquatch during mating season. My god, the first time it happened I thought someone was shooting at me. The absolute worst problem. There's no cure. I changed out the ignition switch per another BMW forum, still happened. I'm not about to drop the $$$$ fro a logic7.


All times are GMT -5. The time now is 12:04 AM.

Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.

 
For the best viewing experience please update your browser to Google Chrome